Reply To: 2 days automatically off

Enable the “use time” option in the general settings.
Regards