Reply To: Captcha SSL image

You have to change the siteurl option of wordpress to https://.
Regards