Reply To: Dashboard is not showing correct dates of reservation

Active the “time” option in the general settings.
Regards