Reply To: Error There is a problem with the form, please check and correct the following:

It’ll probably because your theme uses the jQuery version 1.5.1 and 1.8 or 1.7 are required for the datepicker. But I don’t know if they would break functions of the theme.
Regards