Reply To: firefox

It’s the width of the select field, delete that from your form settings.
Regards