Reply To: Reservation time

Set the correct timezone in wordpress settings.