easyreservation disapeared after update to 6.0

I updated my plugins like always. Now my easyreservation is gone.
I have it still in my activated plugin list (Version Alpha 5) but it is deactivated.
It is not in my header menue, nor in my left main menue.
Even on the webpage i just see the code.

Do I have to update the database also?
I’m not able to do a backup, so I didn’t do it until now…..

Thank you for your help

It’s an alpha. If you cannot backup your database I’d advise staying on 5.0.11 until its final, as you cannot downgrade once you are on 6.X.

You can download the old version here

Free


Regards

Thank you.
If I do so, will my content (reservations) still be there?

Sorry I am a beginner and I usually just use the WP build in updater.
Is there a manual how I install the old version?

Thanks again

If you did not run the database update, yes.

https://www.wpbeginner.com/beginners-guide/step-by-step-guide-to-install-a-wordpress-plugin-for-beginners/

Install a Plugin using the WordPress Admin Plugin Upload

Regards

Perfect I will try this.

What do you think (not guarantee), will my easy reservation run normal, if I update the DB? Could be the easiest way.
———————————
Arrghh: What I did

I stopped the Plugin Version 6, to be able to reinstall the old version.
I uploadet the ZIP via “Add new” like in the manual
An error came up “Folder already exist” “stopped installation”
So I activated the Plugin Version 6 again und a message was on the screen: Thank you for updating the DB. 🙁
Now I have total clean installation. Everything disapeared. What a big mess 🙁
my old formular, calender – everything is gone ….
Any suggestions to recover the old DB and reservations?

I’m not sure it was really updated. There needs to be &do_update_easyreservations=1 in your URL for it to update. That cannot come out of nowherre. Are there orders and reservations?
Regards

No, unfortunately no orders and reservations (any more)
the URL is for e.g.: http://www.xxxxx.de/wp-admin/edit.php?post_type=easy_order

I have the (empty) plugin in the left main admin panel but still not in die black admin header
What I found is the resouce and the Formular, even if the Formular does not show up on the webpage. There ist just the “submit” button, after the unsuccessful update.

—————————————————–

easyReservations version: 6.0-alpha.5
Log directory writable: 1
WordPress version: 5.3.2
Server info: Apache
PHP version: 7.2.28-he.0
cURL version: 7.38.0, OpenSSL/1.0.1t
MySQL version: 5.6.47-87.0-log

That’s good. It means you never ran the updater.

Go to easyReservations -> Settings and make sure the uninstall option is not activated.
Then deactivate und delete the plugin.
Then install http://easyreservations.org/free/

Regards

sounds good. The old reservations (and orders) will stay?
I red somewhere, that after “deleting” the plugin, all data will be deleted.
[Edit: found the checkbox 🙂 It is not checked]

Shall I install the old 5.x version in the link you sent to me?

There’s an option in the settings to delete the data on uninstall. Reservations -> Settings. Make sure it is not activated.

Yes upload the .zip through the plugin uploader.

Regards

Okay, I just found out, that all your links point to the actual version. Can you please send me a deep link to the latest 5.X version?
Thank you

Free

Okay, sorry I never clicked on the word “free” but on “WordPress Plugin”.

Now it worked – you saved my day. Everything is like before.

Thank you!!!

I’ll come back to you before I do the update 😉

You must be logged in to reply in this thread.

Resolved
13 posts