Fatal error

The plugin is not working properly.
I cannot see the calendar in the dashboard.
Also when trying to add a shortcode it gives me the following error:

Fatal error: Uncaught Error: Call to undefined function get_current_screen() in /web/htdocs/www.mysite.com/home/wp-content/plugins/fusion-builder/inc/helpers.php:979 Stack trace: #0 /web/htdocs/www.mysite.com/home/wp-includes/class-wp-hook.php(286): fusion_builder_add_quicktags_button(”) #1 /web/htdocs/www.mysite.com/home/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /web/htdocs/www.mysite.com/home/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /web/htdocs/www.mysite.com/home/wp-content/plugins/easyreservations/assets/js/tinyMCE/tinyMCE_shortcode_add.php(266): do_action(‘admin_print_foo…’) #4 {main} thrown in /web/htdocs/www.mysite.com/home/wp-content/plugins/fusion-builder/inc/helpers.php on line 979

Thanks for your attention

That error is from the fusion-builder, not from easyReservations.
Try to disable it and see if its working then.
Regards

Thanks for the prompt reply.

I have disabled all plugins, apart from EasyReservation and the problem is still there.

In the dashboard (now odd layout and no calendar shown), I found this error “Warning: A non-numeric value encountered in /web/htdocs/www.mysite.com/home/wp-content/plugins/easyreservations/lib/admin/dashboard.php on line 952”

Please open each of your resources settings and save them once. Seems like one resource has no quantity set.
Regards

Thanks again, I deleted the resource without quantity and the latest error disappeared.

However, the plugin is still not working properly, i.e. odd form layout without borders and no calendar in dashboard.

If I disable Fusion builder plugin, the following error appears:
“Failed to load plugin url: http://www.mysite.com/wp-content/plugins/easyreservations/assets/js/tinyMCE/tinyMCE_shortcode_add.js
This error used to be present even with previous theme.

Do you use https? If so you need to replace the http with https in the wordpress general settings URL options.
Else please send me access to support@easyreservations.org
Regards

Thank you very much.
The redirect to Https was already active but incomplete. I modified the wp_options file, wp_config and wp_signup files.
Now the plugin is working again. Dashboard and calendar are fine. The original file error is still there but I will check with the plugin developer.
Thanks again

You must be logged in to reply in this thread.

Resolved
7 posts