Pasted Form Code gets bloated/scrambled

Hello there,

I am using my IDE to write some markup for my custom form.

When I paste that code (Ctrl+Shift+V, without formatting) in the field of my custom form (mysite.org//wp-admin/admin.php?page=reservation-settings&site=mycustomform) and save it a lot of extra xml is generated.

E.g.

<div></div><span class="Apple-tab-span" style="white-space:pre"></span>

Does anyone know a workaround or solution?

Every hint is very much appreciated.

Thanks and kind regards
Ben

It should only add span’s, but no div’s and classes to the span’s. I remember to have it improved in the beta, but could not remove it completely. Try it in the public update coming out next month.
Regards

Thanks for your reply!

If I type it in by hand and save it everything works fine. With no extra code generated.

Seems there is no way to get it working this way with pasting from the clipboard though …
( Or shall I copy it directly to the WP Database … ? 🙂 )

Update:
For anyone interested: I found a solution that works for me.

Just open the Formedit-page (/wp-admin/admin.php?page=reservation-settings&site=form&form=your form) up in Firebug or whatever you use for this and edit the contents of the form-container (#formcontainer) as html. There you can paste your prepared code and save it – voila!

Greetings
Ben

You must be logged in to reply in this thread.