PHP 7.1 Support?

Granted, my client is running one version behind, 3.5 – I switched them to PHP7.1 today and got this error trying to load the site. I checked the change log for the 3.5.1 version but did not see any mention of this issue being resolved. Is this something that will be resolved if they update to the latest version or do they need to wait for an additional hotfix?

[30-Jan-2017 21:13:11 UTC] PHP Fatal error: Cannot unset $this in /home/*******/public_html/wp-content/plugins/easyreservations/lib/classes/reservation.class.php on line 2759

To make this more perplexing, there is no line 2759… that file ends around line 1300… *scratches head*

looks like i found an unset($this) inside the destroy() method… not sure if commenting this line out will have any negative effects… please advise.

You should be able to delete the line without any effects. That’ll problably also be my bugfix for it as it seems you should not destroy a class from inside.
Regards

You should be able to delete the line without any effects. That’ll problably also be my bugfix for it as it seems you should not destroy a class from inside.
Regards

You should be able to delete the line without any effects. That’ll problably also be my bugfix for it as it seems you should not destroy a class from inside.
Regards

Thanks!

You must be logged in to reply in this thread.

Resolved
5 posts