Problem with payment gateway

Hi,

After installing the latest beta yesterday the ogone payment gateway is not working. Previously it was working fine. Can you please let me know the solution. The plugin which i am using is dot interactive ogone payment.

There were no change on the gateways. What exactly do you mean with not working?
Regards

Hi,

The error is An error has occurred; please try again later. If you are the owner or the integrator of this website, please log into the Ogone back office to see the details of the error.

and the explanation for the error in the payment gateway website is as below.

The error “unknown order/1/s/” means that the SHASign you sent us in the hidden HTML fields for the transaction doesn’t match the SHASign constructed/calculated at our end with the details of your order and the signature/password you entered in the SHA-1-IN Signature field in the “Data and origin verification” tab, “Checks for e-Commerce” section of the Technical Information page in your account.

Can you please let me know the solution.

Are you sure the SHA-IN/OUT settings are correct? SHA-1 selected? As of their documentation nothing has changed and I couldn’t find any evidence that more people got that error now. But there are many discussion and things to try out if you google for “unknown order/1/s/”.

Here are a few:

they have asked me to select “Each parameters followed by pass phrase” option under Global security parameters

Go to Configuration > Technical Information > Data and Origin Verification and enter the base URL of your WooCommerce site, i.e. http://www.example.com (if your site uses SSL on the checkout page then don’t forget to include HTTPS in the url: https://www.example.com). On that same page, enter a SHA-IN pass phrase of your choosing. Then scroll to the bottom of the page and hit “Save”.

Maybe ask the ogone support if they have an idea what’s wrong.
Regards

Hi,

As you said we checked all the settings in our website. The problem in the plugin is its not able generate the global security parameters properly. When we check out, this is the code which is being sent to the ogone:

submit.x=119&submit.y=49&ACCEPTURL=&AMOUNT=45000&BUTTONBGCOLOR=&COM=Vol+croisi%C3%A8re%2Fgrand+tour+%281h00+environ%29+for+1+days+%7C+05.06.2014+-+05.06.2014&COMPLUS=82cab03834&CURRENCY=EUR&DECLINEURL=&LANGUAGE=en_US&LOGO=&ORDERID=89&PSPID=AIRSHIPPARIS&SHASIGN=d7f375ba11918859a7a31f92e769c81314f58f96

But as you said each parameter should be followed by the pass phrase which we give and this is the problem.

Please let me know the solution.

Thanks.

The passphrase is only used with each attribute to generate the SHASIGN, not to attach it to the attributes you send.

I think this is the problem:
submit.x=119&submit.y=49

Any idea where that comes from? It’s not in the attributes I define in the code.
Can you give me admin and FTP access?
Regards

i have mailed you all the details. Please let me know the solution.

Thanks.

If I would know a solution I would tell you for sure.

I’ve tried around with the code and am sure the problem is not on easyreservations side. Everything works as the ogone documentation states.

Try to make the SHA-IN and SHA-OUT to be different.
+
The “unknown order/1/s” problem is often related to encoding mismatches. Ogone is default ISO, but Magento is UTF-8. Switch Ogone technical settings to UTF-8 to solve the issue.

Regards

The settings which i am currently having is in UTF-8. Also tried by using different sha-in and sha-out but its still not working.

I’ve tried multiple available codes to generate the shasign with the same result. I’m out of things to try – you’ll have to ask ogone what’s wrong.

I hadn’t had time to read their general terms and conditions to make a test account, but will do so on a flight today. Some gateways have costs if you dont use it afterwards so I have to be carefully…
Regards

We contacted ogone and they told where the problem is. when we fill the form and send the details to ogone, it should be sent as below.

Example of a SHA-1-IN calculation with only basic parameters
Parameters (in alphabetical order)
AMOUNT: 15.00 -> 1500
CURRENCY: EUR
LANGUAGE: en_US
ORDERID: 1234
PSPID: MyPSPID
SHA-IN passphrase (in Technical information)
Mysecretsig1875!?
String to hash
AMOUNT=1500Mysecretsig1875!?CURRENCY=EURMysecretsig1875!?
LANGUAGE=en_USMysecretsig1875!?ORDERID=1234Mysecretsig1875!?
PSPID=MyPSPIDMysecretsig1875!?

Resulting Digest (SHA-1)
F4CC376CD7A834D997B91598FA747825A238BE0A

so the string to hash will be sent and then the SHA-IN key will be generated based on the string to hash. So the problem is when we fill the form in the current version of the plugin it will be like this

submit.x=119&submit.y=49&ACCEPTURL=&AMOUNT=45000&BUTTONBGCOLOR=&COM=Vol+croisi%C3%A8re%2Fgrand+tour+%281h00+environ%29+for+1+days+%7C+05.06.2014+-+05.06.2014&COMPLUS=82cab03834&CURRENCY=EUR&DECLINEURL=&LANGUAGE=en_US&LOGO=&ORDERID=89&PSPID=AIRSHIPPARIS&SHASIGN=d7f375ba11918859a7a31f92e769c81314f58f96

so in the string to hash the sha pass phrase is not getting attached. So this where the problem lies when it calculates the SHA-IN key.

As I mentioned earlier it gets attached, but only to generate the SHASIGN. Here’s the code and it’s exactly as the ogone documentation requires.

Select Code
1
2
3
4
5
6
7
ksort($array, SORT_NATURAL | SORT_FLAG_CASE);
				$string = "";
				foreach($array as $key => $value){
					if(empty($value) && $value !== 0) continue;
					$string .= "$key=$value".$gateway_opt['shapass'];
				}
				$sha = sha1($string);

As you see in line 5 the shapass get’s attached to every attribute.

Regards

I found where the problem is. I installed a fresh easyreservation from your website(not beta). And tried the fill the reservation form. So after filling the form i will book it and there you will get two options.
1. Add another reservation
2. Submit reservation.

So if i select submit reservation and select ogone payment it gives the same error which means the shasign is not matching.

But if i select add another reservation and try to add another reservation and then select submit reservation and ogone payment, the ogone is working fine. So please look at this problem and kindly give me a solution.

If you want you can check through the below link.

http://testserver.canablava.com/booking/

Thanks.

Nice finding, now we come closer. The only difference between the two is the description. For the one that fails it is “Vol baptême /découverte (30mn environ) for 1 days | 21.05.2014 – 21.05.2014” while the other has no uncommon signs.

So please check if it still happen if you take out ê, / and r é. The setting is “title” at the top of the payment settings, as best just enter “test”.
Regards

Thanks. Finally that worked.

You must be logged in to reply in this thread.

Not Support
15 posts